DLM Service Performance Degredation
Incident Report for Solid State Networks
Resolved
AWS is reporting this issue as mostly resolved. Our monitors are showing no new errors or failures.
Posted Sep 28, 2022 - 15:27 MST
Investigating
We are currently monitoring intermittent performance issues with the AWS API Gateway in front of the DLM Service. AWS is currently working to resolve the issue. Until the problem is solved by Amazon, users may be experiencing occasional failures while trying to request Download Manager.

We will update this incident as new information comes from Amazon.
Posted Sep 28, 2022 - 13:44 MST
This incident affected: DIRECT DDP.